Under review

won't show small windows

fran 2 years ago • updated by Ionuț Botizan 2 years ago 9

No matter how much I zoom in or out, I can't see the iPhone 6 or 5 windows it says:

  • the target width is lower than the maximum allowed by your browser window

I'm having this problem as well. Since it updated yesterday with the new interface, I cannot use my presets, and it says the same message:

  • the target height is lower than the minimum allowed by your browser window
  • the target width is lower than the maximum allowed by your browser window

this renders the extension useless for me, as I was using it to put a window on the lower half of a 90 degree rotated screen

Under review

Hi Charlie,

If the presets are the same as before the update, then they are broken and you should update them with the correct values. The old version of the extension tried to resize the window to the desired dimensions but if it couldn't it would fail silently and leave the window as close as it could to the desired sizes. Unfortunately, that behavior is not desirable for the intended audience of this extension (web developers) and it has been removed, with the extension reverting the window size if it couldn't set it to the desired dimensions (usually due to Chrome restrictions).

If you want to achieve the same thing, you need to simply edit the presets and set correct width and/or height values for the window size and not bogus ones like 100 x 100. If your screen's resolution is, let's say, 1920 x 1080, rotated to 90 degrees it would be 1080 x 1920 so your preset should be width=1080, height=960, left = 0, top=960.



I appreiciate the quick reply. I am not a web developer, so I have a hard time understanding this phenomenon. If the window size I desired was too small, why am I able to manually resize the window using the edge handles? I even get that error message when I try to resize to 1920x1080. I am running three displays, and my main laptop display is 3200x1800, with my Windows 7 scaling factor set to 140%. 1920x1080 does not work if I use an old preset, a new one, or manual entry from the bottom of the menu. Page zoom does not seem to make a difference in the outcome. If at all possible, I would prefer to just downgrade to a previous version, as it worked perfectly for my use case.

I have a theory, but I'm typing from my phone so I can't test it.

Meanwhile, you could try the following: Open a regular page, like google.com and manually position the window where you want it to be, then resize it do the desired dimensions by using the edge handles. When it's exactly where you want it to be, open the settings and add a new preset. Don't write the width/height yourself; instead, click on the "use current" link next to the input fields. Do the same for the window's position and leave the resize target set to "window", not "viewport". Save the new preset and try it out. There should be no reason for this not to work.



Here is that attempt, noting that the process you laid out is what I tried originally.
image1image2image3image4image5. I tried it as well with manually entering 1920x1080 to no avail, but those screenshots were too large for the one hoster that's not blocked where I am. I can upload those screenshots later if desired.

This is incredibly weird! :/ I can't think of a single reason that could cause this...

From your screenshots it seems to me that you have a pending Chrome update. Did you try to update Chrome and see if it works afterwards?

I just wanted to say I've also got the same issue and I'm on the latest version of Chrome. I've reset all the sizes and it worked momentarily. But then it reverted back to not working again. Any help would be much appreciated.


Whatever was in the latest updates solved it, i still get a red error message but the window does exactly what I want. Thanks for working on this and providing such a useful extension for free!

Hey Charlie,

I'm happy to hear that. You still get that tiny red message because the window is not set to the exact dimension you requested, it's most likely 1 or 2 pixels off. I discovered that Chrome does some weird things on a display scaling other than 100%: even though the extension requests a specific width or height, Chrome fails sometimes to apply that dimension, even though you can set it manually by dragging the window's edges. I suspect it's due to some math rounding errors...

Anyway, like I said, I'm glad it works now! :)

Best Regards,